build 1996 - new UI, part V

Alpha/Beta versions for early access to new half-cooked features
don
Posts: 130
Joined: Sat Jul 18, 2015 11:03 am
Location: Sydney, AU

Re: build 1996 - new UI, part V

Post by don » Sun Feb 05, 2017 12:21 am

The discoloured UI bug is still here.
Screen Shot 2017-02-05 at 11.20.09 am.png
Screen Shot 2017-02-05 at 11.20.09 am.png (76.26 KiB) Viewed 15136 times
Not sure what might be causing this. Custom fonts?

User avatar
mike
Posts: 806
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: build 1996 - new UI, part V

Post by mike » Mon Feb 06, 2017 3:19 am

JayB wrote:
Sat Feb 04, 2017 9:55 am
Well, I have a mid-2010 MBP, and that might be the reason for that second crash. You say that there's some video/screen/GPU stuff going on? The mid-2010 MBP is a Mac with flawed hardware, namely (I believe) that capacitor next to the discrete GPU, which results in kernel panics in situations where the system is set to "dynamic switching", and the GPU switches from integrated to discrete (or vice versa), and from GStates 2 to 0 (max). So I'm blocking any app from activating the discrete NVIDIA using an app called gfxCardStatus. Several apps (like VLC) want to use (power on) the discrete GPU, because they see it's there, but I'm forcing them to use the integrated GPU. And maybe that's messing things up a bit from time to time. But I haven't noticed anything out of the ordinary with other software, and why it would affect Nimble Commander is beyond my understanding. So it might be something else after all
The thing is, something caused an interface relayout process, and I can't imagine another reason for that.
Anyway, I can't reproduce it nor figure out what happened, there's not enough information.

User avatar
mike
Posts: 806
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: build 1996 - new UI, part V

Post by mike » Mon Feb 06, 2017 6:18 am

hugo187 wrote:
Sat Feb 04, 2017 6:42 pm
I am experiencing a random crash when entering a folder with build 2006. Steps to reproduce:
JayB wrote:
Sat Feb 04, 2017 10:55 am
Another crash; happened when navigating to a directory via quick search, then hitting RETURN to enter the directory.
Ok, I have to admit that this multi-threaded UI updating has been causing more chaos than performance boost.
What is interesting - I can't reproduce this crash even a single time on my 4C/8T machine.
Nevertheless, removed that code entirely, here's the updated build:
http://magnumbytes.com/downloads/previe ... (2009).zip

User avatar
mike
Posts: 806
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: build 1996 - new UI, part V

Post by mike » Mon Feb 06, 2017 6:24 am

don wrote:
Sun Feb 05, 2017 12:21 am
The discoloured UI bug is still here.
Not sure what might be causing this. Custom fonts?
Don, frankly I've no idea what is going on here. Coloring works independently of fonts handling.
Could you provide some more information? For instance
- does it happen in determined way, i.e. for same items?
- what coloring rules are currently set?
- does it happen in any presentation or only in list?

hugo187
Posts: 21
Joined: Thu Feb 02, 2017 1:03 pm

Re: build 1996 - new UI, part V

Post by hugo187 » Mon Feb 06, 2017 9:41 am

mike wrote:
Mon Feb 06, 2017 6:18 am
hugo187 wrote:
Sat Feb 04, 2017 6:42 pm
I am experiencing a random crash when entering a folder with build 2006. Steps to reproduce:
JayB wrote:
Sat Feb 04, 2017 10:55 am
Another crash; happened when navigating to a directory via quick search, then hitting RETURN to enter the directory.
Ok, I have to admit that this multi-threaded UI updating has been causing more chaos than performance boost.
What is interesting - I can't reproduce this crash even a single time on my 4C/8T machine.
Nevertheless, removed that code entirely, here's the updated build:
http://magnumbytes.com/downloads/previe ... (2009).zip
Thanks, Mike. I can confirm the random crashes are gone in build 2009.

don
Posts: 130
Joined: Sat Jul 18, 2015 11:03 am
Location: Sydney, AU

Re: build 1996 - new UI, part V

Post by don » Mon Feb 06, 2017 12:06 pm

mike wrote:
Mon Feb 06, 2017 6:24 am
Could you provide some more information? For instance
- does is happen in determined way, i.e. for same items?
- what coloring rules are currently set?
- does it happen in any presentation or only in list?
Have not noticed a system as yet. Will pay close attention. But so far Items are different.
More to it - if I run with the cursor over - the color gets fixed.

I use default coloring rules. Changed the fonts - that's all.

And it happens in list only, though in all view modes.

don
Posts: 130
Joined: Sat Jul 18, 2015 11:03 am
Location: Sydney, AU

Re: build 1996 - new UI, part V

Post by don » Mon Feb 06, 2017 1:18 pm

don wrote:
Mon Feb 06, 2017 12:06 pm
Have not noticed a system as yet. Will pay close attention. But so far Items are different.
Would take it back - items are the same.
With 2009 there are a lot less of them. And what is interesting, it is always either 20th or 21st entry in the list.
Shorter lists - no issues.
But if one is longer than 30 items , a few items starting 20th or 21st will be discolored.

hugo187
Posts: 21
Joined: Thu Feb 02, 2017 1:03 pm

Re: build 1996 - new UI, part V

Post by hugo187 » Mon Feb 06, 2017 3:12 pm

NC build 2009 is still acting a bit odd with two (or more) windows open. Sometimes I cannot focus the second window. It stops receiving mouse and keyboard input. Then it crashes eventually (attaching crash report). At some point I was able to reproduce the crash at each attempt just by opening a new window (Cmd+N) and pressing Tab to switch to the second pane. The problem goes away with the ~/Library/Application Support/Nimble Commander folder removed, but comes back eventually.
Attachments
Crash_2017-02-06-142820.zip
(17.72 KiB) Downloaded 144 times

don
Posts: 130
Joined: Sat Jul 18, 2015 11:03 am
Location: Sydney, AU

Re: build 1996 - new UI, part V

Post by don » Tue Feb 07, 2017 12:26 pm

Additional point.

After a week of using the new version ( more than a week actually) - I think move to the new API was absolutely correct.

* I like borderless - actually a lot.
* I do not observe any differences in the workflow
* I Appreciate the themes and configurability

All together I am happy with the change and would like to thank Mike for the following things:

* The idea.
* The way how he introduced and carried out the idea.

The second one was also important to me.

User avatar
mike
Posts: 806
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: build 1996 - new UI, part V

Post by mike » Thu Feb 09, 2017 8:24 am

don wrote:
Mon Feb 06, 2017 1:18 pm
Would take it back - items are the same.
With 2009 there are a lot less of them. And what is interesting, it is always either 20th or 21st entry in the list.
Shorter lists - no issues.
But if one is longer than 30 items , a few items starting 20th or 21st will be discolored.
Don, I can't reproduce it, no matter how I try :(
Is there any minimal setup, better to be synthetical, on which this malfunctioning happens all the time?

Post Reply