build 2042 - new UI, part VI

Alpha/Beta versions for early access to new half-cooked features
User avatar
mike
Posts: 803
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: build 2042 - new UI, part VI

Post by mike » Sun Feb 19, 2017 5:08 am

Dammit!
It was that darn "Close windows when quitting an app" system setting again. :shock:
Sorry for the issue, I was testing that saving/restoring code in a different pathway (I have that option turned OFF).
Please use this build, I've fixed it:
http://magnumbytes.com/downloads/previe ... (2053).zip

warpkanal
Posts: 76
Joined: Mon Jan 30, 2017 5:24 pm

Re: build 2042 - new UI, part VI

Post by warpkanal » Sun Feb 19, 2017 1:05 pm

Thx, works again. (if now NC would add the current active tab to its saved state as well ;) )

User avatar
mike
Posts: 803
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: build 2042 - new UI, part VI

Post by mike » Mon Feb 20, 2017 7:00 am

warpkanal wrote:
Sun Feb 19, 2017 1:05 pm
if now NC would add the current active tab to its saved state as well ;)
Actually, I've done it! Alongside with focused side - left or right. (in b2063+, will be available later)

warpkanal
Posts: 76
Joined: Mon Jan 30, 2017 5:24 pm

Re: build 2042 - new UI, part VI

Post by warpkanal » Mon Feb 20, 2017 11:33 am

Cool, thx :!:

JayB
Posts: 142
Joined: Sun Jan 08, 2017 4:38 pm

Re: build 2042 - new UI, part VI

Post by JayB » Tue Feb 21, 2017 4:54 pm

Crash happened, when I ejected a mounted DMG, while I was copying an .app to /Applications from said DMG. It seems that Nimble Commander doesn't check, if file copying/moving processes are still active, when ejecting a volume.

After re-launching, macOS spit out an uncaught exception, but without crashing, then it seemed that the Applications folder needed to be rebuilt, because NC was scanning for a long time, and then it crashed again. After the second relaunch, everything was back to normal again.

I tested it with another app-copy-from-DMG, this time ejecting the DMG shortly before the end of the copying process, and NC didn't crash immediately… the copying process simply halted, and I was still able to cancel it.

Appended is the report for the first crash.
Attachments
NCcrash_20170221.txt.zip
(20.04 KiB) Downloaded 107 times

User avatar
mike
Posts: 803
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: build 2042 - new UI, part VI

Post by mike » Wed Feb 22, 2017 2:03 am

JayB wrote:
Tue Feb 21, 2017 4:54 pm
Crash happened, when I ejected a mounted DMG, while I was copying an .app to /Applications from said DMG. It seems that Nimble Commander doesn't check, if file copying/moving processes are still active, when ejecting a volume.

After re-launching, macOS spit out an uncaught exception, but without crashing, then it seemed that the Applications folder needed to be rebuilt, because NC was scanning for a long time, and then it crashed again. After the second relaunch, everything was back to normal again.

I tested it with another app-copy-from-DMG, this time ejecting the DMG shortly before the end of the copying process, and NC didn't crash immediately… the copying process simply halted, and I was still able to cancel it.
Thanks for reporting.
I believe this issue was already fixed in later builds, for instance in b2053.

JayB
Posts: 142
Joined: Sun Jan 08, 2017 4:38 pm

Re: build 2042 - new UI, part VI

Post by JayB » Sun Feb 26, 2017 6:06 pm

I'm using the new build now (2053)… no issues so far, except for one: there are moments when I can't drop files into a folder, e.g. I select 5 files with CMD-click, then try to move them to a folder—in the current case it's in the same directory—, the folder gets highlighted (in my case with blue lines around it), but dropping the files in there doesn't work.

After that the folder stays highlighted/selected. I need to open a new tab, and then close the old tab to deselect the folder.

Moving the files works by using CMD-C, then navigating into the folder, then hitting ALT-CMD-V

Very strange.

sasha
Posts: 166
Joined: Wed Feb 17, 2016 4:59 pm

Re: build 2042 - new UI, part VI

Post by sasha » Sun Feb 26, 2017 7:38 pm

JayB wrote:
Sun Feb 26, 2017 6:06 pm
I'm using the new build now (2053)… no issues so far, except for one: there are moments when I can't drop files into a folder, e.g. I select 5 files with CMD-click, then try to move them to a folder—in the current case it's in the same directory—, the folder gets highlighted (in my case with blue lines around it), but dropping the files in there doesn't work.

After that the folder stays highlighted/selected. I need to open a new tab, and then close the old tab to deselect the folder.
I can confirm this, although it's a rare error and I haven't found out how to reproduce it. I'm using the same build, classic theme. The highlighted row gets a box of thin yellow lines around it and stays like that even if you change the folder.

Off topic: I really enjoy the new classic mode, great job.

User avatar
mike
Posts: 803
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: build 2042 - new UI, part VI

Post by mike » Mon Feb 27, 2017 4:35 am

JayB wrote:
Sun Feb 26, 2017 6:06 pm
I'm using the new build now (2053)… no issues so far, except for one: there are moments when I can't drop files into a folder, e.g. I select 5 files with CMD-click, then try to move them to a folder—in the current case it's in the same directory—, the folder gets highlighted (in my case with blue lines around it), but dropping the files in there doesn't work.

After that the folder stays highlighted/selected. I need to open a new tab, and then close the old tab to deselect the folder.

Moving the files works by using CMD-C, then navigating into the folder, then hitting ALT-CMD-V
sasha wrote:
Sun Feb 26, 2017 7:38 pm
I can confirm this, although it's a rare error and I haven't found out how to reproduce it. I'm using the same build, classic theme. The highlighted row gets a box of thin yellow lines around it and stays like that even if you change the folder.
Confirm, there was a glitch in list mode, fixed in b2076.
sasha wrote:
Sun Feb 26, 2017 7:38 pm
Off topic: I really enjoy the new classic mode, great job.
Take a look at b2076, monospaced fonts should look better without text tightening.

Post Reply