Bug - Deleting on NAS takes very long

Questions, glitches, bugs and crashes
Post Reply
User avatar
bchuter
Posts: 76
Joined: Tue Aug 08, 2017 9:37 pm
Location: Pretoria, South Africa

Bug - Deleting on NAS takes very long

Post by bchuter » Wed Jan 02, 2019 5:49 pm

Hi Mike

I've been meaning to raise this.
I've noticed that when i delete files on my NAS (Synology with BTRFS) it literally takes ages to delete files?

I just deleted 34 files on the NAS (ranging from sizes of 300Mb to 1Gb) and it took over 3mins to complete this task?
Deleting should be almost instant not?
Bradley Chuter

User avatar
bchuter
Posts: 76
Joined: Tue Aug 08, 2017 9:37 pm
Location: Pretoria, South Africa

Re: Bug - Deleting on NAS takes very long

Post by bchuter » Wed Jan 02, 2019 5:57 pm

Hmm, as a test i just tried the same thing with Double Commander and i also get slow delete speeds.
I can also hear the discs ticking over like mad during these delete operations. Like disk access noise.
could this be a MacOS thing or Linux or File system (BTFRS) issue, and possibly a Synology NAS issue......if memory serves me correctly
on windows when doing the same deletes they are near instant.
Bradley Chuter

moonrak
Posts: 28
Joined: Thu Sep 29, 2016 12:42 pm
Location: Rio Grande, Argentina

Re: Bug - Deleting on NAS takes very long

Post by moonrak » Wed Jan 02, 2019 11:44 pm

Hi,
If you are really hearing mechanical tick noises, that might be the harbinger of a disk failure.
Just my 2 cents.
Carlos

User avatar
bchuter
Posts: 76
Joined: Tue Aug 08, 2017 9:37 pm
Location: Pretoria, South Africa

Re: Bug - Deleting on NAS takes very long

Post by bchuter » Thu Jan 03, 2019 8:19 am

moonrak wrote:
Wed Jan 02, 2019 11:44 pm
Hi,
If you are really hearing mechanical tick noises, that might be the harbinger of a disk failure.
Just my 2 cents.
Carlos
Hi there
no, it was probably a bad choice of words. I just meant it was reading the disk like mad.
Both disks are healthy (per SMART in Synology)
Bradley Chuter

User avatar
mike
Posts: 786
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

Re: Bug - Deleting on NAS takes very long

Post by mike » Sun Jan 06, 2019 10:33 am

Hey Bradley,

It really depends on a filesystem, and also on a particular file layout there.
Some filesystems are just notorious for slow deletion time, especially indirects-based one like Ext3.

NC itself doesn't do anything special if we're talking about a real "mounted" filesystem - its behaviour shouldn't be different from Unix "rm" in this regard.
You can check if there's a difference if you delete files via rm in terminal.

Speaking of Windows - maybe it was moving these files into some kind of Recycle Bin?
This operation, of course, would be almost instant.

Post Reply