F.A.Q.

Questions, glitches, bugs and crashes
Post Reply
User avatar
mike
Posts: 937
Joined: Thu Jul 16, 2015 5:35 am
Location: Exeter, UK

F.A.Q.

Post by mike » Sat Dec 19, 2020 8:44 am

As sometimes the same questions arise over and over in the forum and in the mail correspondence, they will be gradually collected in this post.

- NC crashes/behaves incorrectly/etc. Can you fix it?
- Probably. However, often is hard to impossible to track the problem down without a detailed description of a setup and a set of reproducible steps. So if you'd like this issue to be fixed - please, spend some time describing in details what has happened and how that could be reproduced.

- Preview lacks the feature XXX, is it possible to add it?
- No. The entire preview functionality is managed by macOS via the Quick Look framework (https://en.wikipedia.org/wiki/Quick_Look). Rendition and behaviour for various file types is provided by various plugins in that system-wide framework, NimbleCommander has nothing to do with it. Currently it doesn’t even have any content-specific logic. While it’s possible to start providing special handling for some specific file types, e.g. images, it would require significant resources investment to implement, cover with tests and maintain, which is out of the scope now.

- Can Nimble Commander access iCloud storage?
- NC does not provide a first-class citizen access to iCloud. The reason for that is that Apple doesn’t have an official API to allow applications to directly manipulate items outside their own containers. At least that’s my understanding of the status quo at the moment (I’d be glad to be proven wrong). Having said that, it’s possible to manually navigate into ~/Library/Mobile Documents/com~apple~CloudDocs and access the items there using a normal UI of NC. This usually works, however there’s no guarantee that content of that folder is properly synchronised.

- NC crashes with EXC_BAD_INSTRUCTION
- This was observed when macOS Catalina was installed on hardware that is not officially supported. NC/x64 requires SSE4.2 since v1.2.9, which is available on all Mac models officially supported by Catalina. But if this OS version was installed on machine with a CPU without these instructions, NC v1.2.9+ simply cannot run. The only possible workaround is using an older version.

- How to download a previous version?
- All previous releases are available here: https://magnumbytes.com/downloads/releases/old/

- Do you plan to add capabilities to modify existing archives?
- There are no such plans. Reasons why were discussed here: viewtopic.php?f=6&t=205.

Post Reply